Login and Latency Issues

Incident Report for FastSpring

Resolved

This incident has been resolved.
Posted Sep 19, 2023 - 23:47 UTC

Investigating

We are currently experiencing API latency due to an issue with AWS. Log in, app speed, and API access may be impacted.
Posted Sep 18, 2023 - 19:04 UTC
This incident affected: FastSpring System.