Dashboard, Springboard and Stores are Down
Incident Report for
FastSpring
Resolved
We have resolved the issues with Springboard, Dashboard, and all stores. We apologize for the earlier inconvenience.
Posted
Aug
14
,
2019
-
14:27
UTC
Investigating
Springboard, Dashboard, and all stores are currently unavailable. We are working to resolve the issue.
Posted
Aug
14
,
2019
-
14:05
UTC
This incident affected: FastSpring System.
×
Subscribe to Incident
Subscribe to updates for
Dashboard, Springboard and Stores are Down
via . You'll receive .