Payment Methods not available for Classic store
Incident Report for FastSpring
Resolved
This incident has been resolved
Posted Aug 16, 2024 - 17:10 UTC
Investigating
We have a number of reports of Credit Cards not being presented a payment option for customer on Classic stores only
Posted Aug 16, 2024 - 14:51 UTC
This incident affected: FastSpring System.