Missing rebills or rebill delay
Incident Report for FastSpring
Resolved
Any missing subscription rebills will be processed later today or tomorrow.
Posted Apr 18, 2022 - 19:27 UTC
Identified
Not all subscription rebills from Apr-18 have been processed. We have fixed the root cause.
Posted Apr 18, 2022 - 19:26 UTC
This incident affected: FastSpring System.