Intermittent Download Issues
Incident Report for FastSpring
Resolved
The issue with our third-party file hosting partners has been resolved. We apologize again for the inconvenience.
Posted Oct 23, 2019 - 01:30 UTC
Investigating
Due to an issue with our third-party file hosting partners, customers may intermittently encounter error messages when attempting to download their file fulfillments. Our partners are aware of the issue and are working to resolve it. We apologize for the inconvenience.
Posted Oct 22, 2019 - 17:52 UTC
This incident affected: FastSpring System.