Scheduled Maintenance – Platform Update

Scheduled for May 17, 02:00 - 03:00 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted Apr 21, 2026 - 15:39 UTC

Scheduled

Please be advised that FastSpring will be performing a scheduled maintenance for an infrastructure upgrade that will require a brief interruption of the services on the FastSpring platform.

Maintenance Window:

UTC (Coordinated Universal Time)
Sun, May 17, 2026 — 02:00–03:00

PT (Pacific Time)
Sat, May 16, 2026 — 7:00–8:00 PM

Impact:
During this time:
- Sellers will be unable to update stores or products
- Buyers will be unable to complete purchases

Additional Information:
- This update supports ongoing security and infrastructure improvements
- No action is required; however, you may want to inform your customers of this temporary interruption.
Posted Apr 21, 2026 - 15:31 UTC
This scheduled maintenance affects: FastSpring System.