Investigating Contact Information Error
Incident Report for FastSpring
Resolved
The issue has been resolved. We apologize for any earlier inconvenience caused by this issue.
Posted May 31, 2018 - 23:03 UTC
Update
Some contextual orders for sellers include an error in the contact information occurring over 05.22.2018 and 05.29.2018. We are targeting a release 05.31.2018 that will correct those records.
Posted May 31, 2018 - 18:36 UTC
Update
We are continuing to monitor for any further issues.
Posted May 30, 2018 - 00:14 UTC
Monitoring
We have identified the issue and are working on correcting the contact records.
Posted May 29, 2018 - 18:52 UTC
Identified
Some FastSpring systems might be currently experiencing issues. We are aware of the issue(s) and are actively working to fix it.
Posted May 29, 2018 - 15:15 UTC
This incident affected: FastSpring System.