UPI Issues

Incident Report for FastSpring

Identified

The issue has been identified.
Posted Apr 09, 2026 - 20:05 UTC

Investigating

We’re currently experiencing issues with some UPI transactions. Payments made using VPA handles such as @okhdfcbank, @okaxis, and @okybl via GPay and PhonePe may fail or be declined.

Payments using other UPI apps or different VPA handles are working normally.

Our partner banks are actively working to resolve this issue. We’ll share updates as soon as more information becomes available.
Posted Mar 24, 2026 - 00:00 UTC