AWS degradation causing email failure
Incident Report for FastSpring
Resolved
The AWS Lambda issue has been resolved, although it is throttled. Our email processing has resumed. We are continuing to monitor the services.

Our queuing system is currently processing backed up events, including webhooks, however because of throttling from AWS on the backed out events, there could be delays in processing the events.
Posted Jun 13, 2023 - 21:41 UTC
Update
Update 1: the issue is affecting webhooks as well as fulfillments.
Posted Jun 13, 2023 - 21:17 UTC
Investigating
AWS is experiencing degradation which is causing our emails to fail. We are investigating the issue.
Posted Jun 13, 2023 - 20:19 UTC
This incident affected: FastSpring System.