Brief disruption
Incident Report for FastSpring
Resolved
This incident has been resolved.
Posted 11 months ago. Nov 15, 2018 - 23:09 UTC
Update
We are continuing to monitor for any further issues.
Posted 11 months ago. Nov 15, 2018 - 23:07 UTC
Monitoring
We experienced disruption in our infrastructure between 1:40 pm PT to 1:53 pm PT. We have identified and resolved the issue. We continue to monitor our systems
Posted 11 months ago. Nov 15, 2018 - 22:59 UTC
This incident affected: FastSpring System.