Classic Invoice Product Names

Incident Report for FastSpring

Resolved

All invoices should display correctly. The issue is resolved.
Posted Jun 20, 2023 - 16:32 UTC

Monitoring

We are working to clean up already viewed invoices, however, the problem is no longer occurring.
Posted Jun 20, 2023 - 16:31 UTC

Update

The root cause is now known and a fix for expected invoices is expected tomorrow.
Posted Jun 20, 2023 - 16:16 UTC

Identified

Invoices viewed from now will include the product name. Previously viewed invoices may still not include product names. We are working to fix these.
Posted Jun 20, 2023 - 16:15 UTC

Investigating

Product names are not properly showing on invoices for Classic stores.
Posted Jun 16, 2023 - 00:00 UTC
This incident affected: FastSpring System.