Unable to accept PayPal EUR from European Economic (EEA) region
Incident Report for FastSpring
Resolved
This incident has been resolved.
Posted May 20, 2024 - 19:46 UTC
Monitoring
Paypal EU transactions are going through successfully. We are continuing to monitor the situation.
Posted May 12, 2024 - 09:20 UTC
Update
Processing of PayPal EUR transaction from EEA region is back to normal. We are still investigating the issues with last nights recurring charges. Thank you for your patience and co-operation at this time.
Posted May 11, 2024 - 18:48 UTC
Update
We are continuing to investigate this issue.
Posted May 11, 2024 - 17:05 UTC
Investigating
We are currently investigating this issue and will provide an update once there is more information.
Posted May 11, 2024 - 17:05 UTC
This incident affected: FastSpring System.