Rebills running behind schedule
Incident Report for FastSpring
Resolved
All subscription rebills are now up to date
Posted Dec 18, 2023 - 22:56 UTC
Identified
The issue has been identified that that rebills are running behind schedule but we expect the rebills to catch up within the next 24-36 hours.
Posted Dec 18, 2023 - 17:23 UTC
This incident affected: FastSpring System.