PayPal down

Incident Report for FastSpring

Resolved

We are no longer seeing the error in our logs and PayPal orders are completing successfully
Posted Oct 16, 2025 - 17:33 UTC

Investigating

FastSpring has received alerts confirming that PayPal is down.
We will continue to monitor and will update you with changes.
Posted Oct 16, 2025 - 16:54 UTC