SEPA Payment Processing Disabled
Incident Report for FastSpring
Update
We are continuing to work on a resolution for this issue. We are waiting on our banking partner to give the go-ahead to re-enable the payment method. We expect SEPA to still be unavailable for at least a week longer or perhaps more. We will keep you updated here.
Posted Sep 28, 2022 - 15:32 UTC
Update
We expect the outage might extend until approximately the end of next week (Sept-16). Any orders not currently fully settled should complete when the payment method is back online. We continue to post updates here.
Posted Sep 08, 2022 - 18:56 UTC
Identified
SEPA payment processing has been removed as a payment option for new orders because of an issue with our processing partner. We will re-enable SEPA as a payment method when available. Subscription rebills are not affected. We project the problem will be resolved Monday. We will update as needed on this page.
Posted Sep 01, 2022 - 12:00 UTC
This incident affects: FastSpring System.