Paypal Outage
Incident Report for FastSpring
Resolved
We see consistent signs of recovery for Paypal orders. Payments are operational.
Posted Oct 16, 2024 - 21:10 UTC
Monitoring
We are seeing signs of recovery. Paypal is reporting that they have mitigated the issue and are also seeing recovery. We will continue to monitor.
Posted Oct 16, 2024 - 20:33 UTC
Investigating
We are investigating the impact of a Paypal outage starting Oct 16, 17:35 UTC. You may also refer to Paypal's status page here - https://www.paypal-status.com/incident/production
Posted Oct 16, 2024 - 20:04 UTC
This incident affected: FastSpring System.