SVB Payout
Incident Report for FastSpring
Resolved
This incident has been resolved.
Posted Mar 13, 2023 - 23:59 UTC
Identified
To all our Customers, Given the current circumstances with Silicon Valley Bank (SVB), FastSpring will not be making any payouts to SVB accounts. Over the next 24 hours, FastSpring will contact each impacted seller individually to work out other arrangements.
Posted Mar 12, 2023 - 20:41 UTC
This incident affected: FastSpring System.