Database Upgrade
Scheduled for Oct 9, 02:00 - 06:00 UTC
Update
UPDATE:

We have moved the date of the update by one week. The planned work will now happen on

Date: Saturday, October 8, 19:00 - 23:00 PST (UTC: Sunday, October 9, 2:00 - 6:00)

In preparation, there will also be a brief outage of up to two minutes on

Date: Wednesday, September 21, 19:00 - 19:02 PST (UTC: Thursday, September 22, 2:00 - 2:02)

Note: This message may be modified with more information leading up to the maintenance window. Please check back here for the latest news or updates.

For any questions/concerns, please contact FastSpring Support
Posted Sep 14, 2022 - 15:32 UTC
Scheduled
FastSpring Advisory

Please be advised that FastSpring will be performing scheduled maintenance for an infrastructure security upgrade that will require a brief interruption of services on the FastSpring platform.

Date: Saturday, October 1, 19:00 - 23:00 PST (UTC: Sunday, October 2, 2:00 - 6:00)

Impact: During this maintenance window, you will not be able to make any modifications to your stores or products, test stores will be inoperable, and customers will not be able to complete a purchase from your stores.

We understand that service interruptions are very disruptive to your business, and we strive to minimize them. Our regular deployments of features and bug fixes every two weeks do not require a maintenance window or downtime. In such cases, we strive to make it seamless for our buyers and sellers. In this specific case, however, we are required to perform this maintenance by our infrastructure provider.

In order to minimize the impact of the interruption, we have chosen a day and time when the number of orders is at its lowest. Our goal is to complete the upgrade in less time than the window provided, to further reduce the impact.

What will be the effects on my store?

Any attempt to load a store (web storefront, classic stores, account management portal, etc) or backend (dashboard and springboard) URL will show a splash page asking customers to return after the operation is complete. Calls to the API or SBL will return a 503 http status header with a maintenance message in the body of the response. Any operation with Store Builder Library (SBL) will not function and would trigger a data-error-callback function (if defined). In effect, popup stores will not load.

Next steps:

You might consider creating a secondary banner informing your buyers of the downtime. This is recommended, but not required. That way, your buyers have a secondary display to notice the downtime.

Note: This message may be modified with more information leading up to the maintenance window. Please check back here for the latest information or updates.

For any questions/concerns, please contact FastSpring Support
Posted Sep 09, 2022 - 14:02 UTC
This scheduled maintenance affects: FastSpring System.