Degraded performance for Dashboard, Springboard and Stores
Incident Report for FastSpring
Resolved
Performance issues have been resolved. We apologize for the earlier inconvenience.
Posted 2 months ago. Aug 14, 2019 - 14:45 UTC
Investigating
Dashboard, Springboard and Stores are back up but we are experiencing degraded performance. We are continuing to work to improve performance.
Posted 2 months ago. Aug 14, 2019 - 14:27 UTC
This incident affected: FastSpring System.