Classic Platform Stores down
Incident Report for FastSpring
Resolved
This incident has been resolved.
Posted about 1 year ago. Jul 31, 2018 - 12:39 UTC
Investigating
Stores on our classic platforms are now down. We are currently investigating and will update you as needed.
Posted about 1 year ago. Jul 31, 2018 - 12:10 UTC
This incident affected: FastSpring System.