PayPal Down

Incident Report for FastSpring

Resolved

This issue has been resolved by PayPal.
Posted Nov 21, 2024 - 13:25 UTC

Investigating

PayPal appears to be down. We are investigating.
Posted Nov 21, 2024 - 13:02 UTC
This incident affected: FastSpring System.