Intermittent Errors Accessing Storefronts, Dashboard and Springboard
Incident Report for FastSpring
Resolved
This incident has been resolved and we apologize for any inconvenience caused for you or your customers.
Posted 4 months ago. Jun 11, 2019 - 17:55 UTC
Investigating
We briefly experienced an issue that could result in errors when attempting to log in to Dashboard and Springboard. Storefronts were also temporarily affected. All systems are functioning normally now, but we are continuing to investigate the cause of the brief issue.
Posted 4 months ago. Jun 11, 2019 - 17:35 UTC
This incident affected: FastSpring System.