Missing Webhooks and Duplicate Buyer Notifications

Incident Report for FastSpring

Resolved

Root causes have been identified and solutions are applied. New webhooks will now fire as expected. We will be working towards identifying missing events. Notifications to customers will not continue to be duplicated going forward.
Posted Feb 17, 2022 - 22:49 UTC

Update

We are continuing to investigate, and we have been testing out multiple solutions. We appreciate your patience.
Posted Feb 17, 2022 - 20:40 UTC

Identified

We have identified the root cause of the issue. Solutions are currently being tested.

We have also determined that multiple notifications were sent to buyers for some subset of orders. The root cause is the same.
Posted Feb 17, 2022 - 16:53 UTC

Investigating

We are currently investigating the issue.
Posted Feb 16, 2022 - 19:30 UTC
This incident affected: FastSpring System.